OpenRoads Designer CONNECT Edition SDK Help

CreateByCenterRadiusStartDirectionSweepAngle(DPoint3d, Double, Double, Double, Double) Method

Constructs a circular arc element

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  CircularArc CreateByCenterRadiusStartDirectionSweepAngle( DPoint3d center,double radius,double startDirection,double sweepAngle,double tol)

Parameters

SettingDescription
  DPoint3d Center of the circle
   Radius of the circle
   Start direction of the arc
   Sweep angle of the arc
   tol for arc creation

Return Value

CircularArc A circular arc element

See Also